Start a new topic

Sample APK Does Not Open on Headset

Hello! I've been unable to get any Unity app to open on the headset. I can't get the APK from Qualcomm to open (in the SDK folder you shared last week); and I can't get a new Unity project with the imported SDK to open either.When I open either app, it just displays a blank screen. And about 2/3rds of the time, the app (on the "host device", i.e. the Motorola phone that the headset is hooked up to) crashes with the following stack trace:

E CRASH   : Version '2020.3.17f1 (a4537701e4ab)', Build type 'Release', Scripting Backend 'il2cpp', CPU 'arm64-v8a'
E CRASH   : Build fingerprint: 'motorola/hiphi_gu/hiphi:12/S1SHS32.55-78-10-3/2b53eb-a73e7d:user/release-keys'
E CRASH   : Revision: 'pvt2'
E CRASH   : ABI: 'arm64'
E CRASH   : Timestamp: 2022-10-03 13:34:33-0400
E CRASH   : pid: 7001, tid: 7015, name: FinalizerDaemon  >>> com.Qualcomm.SnapdragonSpacesSamples <<<
E CRASH   : uid: 10366
E CRASH   : signal 11 (SIGSEGV), code 1 (SEGV_MAPERR), fault addr 0x77e0070210
E CRASH   :     x0  b40000799dc4b370  x1  00000078c4833f50  x2  00000077e0070210  x3  0000000000000000
E CRASH   :     x4  0000000000000000  x5  0000000000000000  x6  0000000000000000  x7  0000000000000000
E CRASH   :     x8  18eea0184b8329a2  x9  18eea0184b8329a2  x10 0000000000430000  x11 0000000000080100
E CRASH   :     x12 0000007861e74ca8  x13 0000000000000002  x14 00000078d7edec34  x15 00000000ebad6a89
E CRASH   :     x16 0000007852700af4  x17 0000007861e76080  x18 000000785b2f0000  x19 b400007a4dc39f00
E CRASH   :     x20 0000000000000000  x21 00000078c4833f50  x22 0000000000000000  x23 b400007a4dc39fb0
E CRASH   :     x24 00000078c4833f50  x25 0000000000000002  x26 000000000000006d  x27 0000007861e77000
E CRASH   :     x28 0000007861e76090  x29 0000007861e76090
E CRASH   :     sp  0000007861e76080  lr  00000078d80d7648  pc  0000007852700af8
E CRASH   : backtrace:
E CRASH   :       #00 pc 0000000000891af8  /data/app/~~ffaLtPx5_mk9h-i4HwP8Ag==/com.Qualcomm.SnapdragonSpacesSamples-kZDZQeCz9adDnUASgJsU0A==/lib/arm64/ (BuildId: b846738c1d8066a1bc875d6ff4aaba38eacb31ab)
I WindowManager: WIN DEATH: Window{ed16f9d u0 com.Qualcomm.SnapdragonSpacesSamples/com.qualcomm.snapdragon.spaces.spacescontroller.ControllerActivity}

From the logs it looks like Unity tries to open, but ARFoundation fails to initialize the XR subsystem:

I Unity   : [XR] [516836617392] [13:34:32.847][Error  ] xrDestroySession: XR_ERROR_HANDLE_INVALID
W Unity   : No active UnityEngine.XR.ARSubsystems.XRSessionSubsystem is available. Please ensure that a valid loader configuration exists in the XR project settings.
W Unity   : UnityEngine.XR.ARFoundation.SubsystemLifecycleManager`3:GetActiveSubsystemInstance()

I should note that all of this is from the example APK created by Qualcomm themselves. Their documentation states that you should troubleshoot your own application not working by trying out their sample APK. But their sample APK doesn't even work. I've tried everything else I can come up with: clean restart, updating the host device OS version, perusing their docs for anything I've missed. Nothing has worked. 

Does anyone have tips on how to fix this? Thank you for your time and help!

1 Comment

Copying from a ticket - as these are the steps we're going to tell you to do to help us narrow down where the error could be.

Hi Ketaki,

So let's eliminate a few things - first make sure that your glasses are connected correctly.
Note the comment about the USB-C cable.
Verify that you are running a recent version of Spaces Services (0.7.0 is a good one) - long press the Snapdragon Services icon and bring up App Info - the version number is at the bottom
Reboot your phone, plug in the glasses and let them boot up.
Run the Unity samples that come with the Snapdragon Services - they pretty much always work. Always exit the sample using the Quit button to gracefully shut things down.
If that fails, then make sure the Spaces Services is NOT running (Press Spaces Services icon, and force stop if it's running) unplug/replug the glasses, let them boot and try again. 
If this fails 3x in a row without rebooting the phone, then we've got an issue. It's not unusual to get a fail to launch a time or two.

If the samples work then you should be able to create Spaces apps yourself. If they fail then there's some issue and we'll assist in getting you up and running.
Please send me the phone's serial number (Settings->search for "serial" - it's a 10 character string)

- Ron Fosner
Spaces Support Team
Login or Signup to post a comment