Start a new topic

My glasses do not connect when I plug them into my phone - I get this a flashing icon

You have followed the following steps and understand how to boot the glasses - but you get a flashing error logo instead.

If you see this, then this indicates that there’s no supported device connected.
This is likely connectivity issue – disconnect USB cable and reconnect.
If it persists try a different high-quality USB cable

This Indicates that the connected device is missing software. Make sure that you've completed all the steps in the Spaces Setup-Guide. When you've registered you device and received notification that we've pushed software to your device, then when you plug in the A3 glasses there should be an update (or two) that gets pushed to your glasses. Use the Lenovo Companion to verify that you have correct version of the software installed (Step 10 on the Set-up Guide)

My headset is having the top issue where it shows the cable is the issue, but I've tried 4 different usb-c cables and even a thunderbolt 3 usb-c and i'm still having the issue. Tried plugging into both a desktop & the motorola phone.

The USB-C cable that comes with the glasses (with the 90° connector) should work. I would test it between two known-good devices and if it fails, then contact Lenovo. In the mean-time we've have good luck with any high-quality USB-C cable. Make sure that when you connect your phone to a PC using that cable you actually get a connection (both the phone and the PC will tell you it's connected). I've seen more phone connectivity issues than glasses connectivity issues.

 I'll try to get a few recommendations for replacement cables.

Hi Ron, Still having the issue with the cable (first image). Tried different cables and nothing changed, tried also the phone factory reset and nothing changed. I can use the glasses for example to control the camera of the 3d model viewer app coming from Lenovo, I can’t see the rendering in the glasses, but If I move the head while wearing the glasses, I can see the camera moving on the phone while the app is open. So it seems that the glasses communicate with the phone.

I'm also suddenly experiencing the first error (has been working fine up until now). Tried both the included cable and several alternates- the headset boots up and then begins flashing the first error image.

how to just reflash the firmware?

is that pin that comes with the glasses meant for a little hole somewhere?

should i push it in there before plugging it into power and that will reset to the factory firmware?

will the motorola edge+ phone then detect that it needs to send an update and send the latest firmware?

need to reflash my glasses but the glasses wont reflash because it already has the latest firmware chicken and egg

If you still need to reset the glasses you might need to contact Lenovo Support. What we can do from here is force an update of the firmware on the glasses. If you wish to try this please send a ticket requesting us to push updated firmware to your glasses - you will need to include the serial number of your registered glasses. Please feel free to reach out to our support team if you need assistance - we are here to get you started.

- Ron Fosner Snapdragon Spaces Support


Do you have a new devkit? It might be possible you're running into this issue

Otherwise please provide some more info about your setup - Glasses firmware version & Motorola Edge Android version.

Please ensure you are using the original cable that comes with the glasses.

If this issue still persists, try plugging the glasses directly into a USB-C power brick plugged into the wall for 10 minutes, then try plugging the glasses back into the phone. This may resolve the issue as an onboard micro-battery may occasionally need a little bit of a charge.


I am facing the same single x issue with the glasses. The glasses were working, until I switched to another Google account on the phone. Nothing has changed in terms of software. The lenovo companion app detects the glasses as connected. I am using the provided USB cable with Motorola smartphone. Tried "charging"  the glasses. but it didn't help


I am having the same single x issue with glasses. They suddenly stopped working. The only thing that changed is the Google account on the motorolla phone. I am using the original type c cable . Lenovo companion app detects the glasses as connected when in plug them in. Tried the method of plugging the glasses directly into a USB-C power brick, but it didn't help. Does anyone have any other solutions?

Hi Danyl,

You can start the process for getting a replacement cable by emailing Lenovo Integrated Solutions Support  at

Include the contents of this forum post and the serial number of your Moto Edge phone in the email.
The serial number can be found in using the Android Settings app at "About phone -> Model -> Serial number"

But if it's not an option, this alternative should also work (1m or less is preferable).

Hope it helps.

 - Norbert

Login to post a comment