Start a new topic


Hello, we're trying to fit the Snapdragon Spaces SDK into our existing project (and strip out the Meta ones).

We believe it is setup correctly in Unity, but on running on the headset, we can only hear the game, rather than see it (e.g. the music is playing fine).

I've attached the log from trying to run it on the VRX, in the hope you could notice if we're doing something stupid on our end.

Early errors are:

2024/02/12 13:45:53.667 5982 5982 Error Spaces-LaunchHelper No Viewer device found to start application on!

2024/02/12 13:45:53.955 5982 6033 Error libprocessgroup set_timerslack_ns write failed: Operation not permitted

2024/02/12 13:45:53.982 5982 6033 Error OpenXR-Loader Error [GENERAL | xrEnumerateInstanceExtensionProperties | OpenXR-Loader] : RuntimeInterface::LoadRuntime skipping manifest file , failed to load with message "dlopen failed: library "" not found: needed by /data/app/SpacesServicesRuntime/lib/arm64/ in namespace classloader-namespace"


(162 Bytes)

Nice to hear, updating the Unity version clears intermediate files as well. Perhaps it was that after all :) 

Hey Simon, 

Just to update - updating to didn't do anything, but migrating to Unity 2023 miraculously solved all of the issues and allowed samples and our experience to load perfectly.

Thanks Simon, we're on versionName=0.19.3 (according to ADB).

What's curious is the Spaces examples worked on the headset for us (headset tracking, not controllers), but then on the next build, didn't. I believe the VRX updated from a lower firmware version to the VRX_user_S9800001_2403081557_kona  version between these two tests, but I can't be sure because the VRX it updated automatically.

I'm going to quickly update to and try building.

If it fails, I'll come back with the unfiltered logs and OpenXR and XR Plugin Management versions, too.

Hi again, some notes here

  • We do not officially support Unity 2022 yet. The error is likely not caused by that - other developers are using it successfully. 
  • The switch to 0.17.0 is only necessary if you are not upgrading your VRX. With the recent firmware update you should be able to use 
  • It sounds like OpenXR is not starting up, hence no head tracking and just rendered in a box. 
  • The Snapdragon Spaces Samples app that comes with the SDK package can be run on any Snapdragon Spaces device, MR/VR/AR. Is it not working on your VRX? 


  • Try to delete the project's intermediate folders and doing a clean build to rule out that something got cached when downgrading the project. 
  • You should be able to use now. Please try if you see the same result with the newer version of Snapdragon Spaces. 

More details needed on:

  • If you are using Unity 2022, can you please post the versions of the OpenXR plugin and XR Plugin Management you are using? 
  • Your log is incomplete and only shows Unity related logs. Can you please post a full unfiltered version of it?
  • I'm not aware of S980 firmware being publicly released. Can you please check the version of the Snapdragon Spaces Services on the device? Here a guide on how to retrieve it via adb

Hi Simon! Thanks for your response. Since your message, we have:

- Updated our Unity to 2022 (due to multiple issues with 2021 generally)

- Switched to Spaces SDK 0.17.0

- Managed to update the headset firmware (VRX_user_S9800001_2403081557_kona)

We now get an image (no more fully black environment), but that image just renders in a box, like the app is running in a window in the home environment of the headset (and controllers are obviously not "in" the game).

We have a log of the error: and I imagine it's this line that is pointing out the error

- Warn Unity Plugins: Couldn't open UnityOpenXR, error: dlopen failed: library "UnityOpenXR" not found

But I'm not sure why this isn't being found. Do you have any ideas? Is there a working VRX example anywhere (or is it all for the AR glasses?)

Thanks for any help!

You are likely running into a backward compatibility issue. Read more on Snapdragon Spaces backward compatibility at 

If your VRX is using firmware version 829 or lower, you cannot use the SDK Plugin, but need to use the 0.17.0 one which is available to download at 

When your VRX is on firmware higher than 915, you can start using the SDK Plugin.

Hope that helps!

Login or Signup to post a comment