Start a new topic

Issues with Snapdragon Spaces SDK versions 0.15.1 and above

I am trying use these versions of Snapdragon Spaces SDK and get issues with sample scenes (Main Menu):


When running in Unity Editor I got this error:

DllNotFoundException: libInterceptOpenXR assembly:<unknown assembly> type:<unknown type> member:(null)


When running in Unity Editor, it seems to work, but Gaze Pointer is invisible (in scene view I can see it is reacting with filling circle on hover).


works fine in the Editor, Gaze Pointer is visible (except for this issue: Gaze issue )

Please share solutions for using these versions in the Unity Editor.
However we use Argo from Digilens, and we need to use 0.13.0 or 0.14.0, so the most important is to solve this Gaze issue

Thanks in advance for help

Hi Tomasz, 

Is your Digilens device using 0.19.1 Spaces Services or a lower version? 

You may be running into an old runtime backwards compatibility issue. For more info on backwards compatibility please check the FAQ

Generally, we provide old app backwards compatibility not old runtime backwards compatibility. There was an old runtime backwards compatibility breaking change in 0.19.1 - which shows this error when used in combination with a lower runtime version.  

There are two ways to work around this, 

- Update your Spaces Services to match or exceed the plugin version

- Downgrade your Spaces Plugin version to match the Spaces Services version installed on your device.

The gaze pointer was reworked in 0.15.0 when Composition Layer support was added and is now vastly different from the previous version. I'll check if the engineers who implemented it have advice.

It sounds like a duplicate input binding. Please check your interaction profile for any duplicates. 

Thanks for the answer.
However, my question (this one repeated below) is about possibility of running SnapdragonSpaces SDK in Unity Editor (not on the device build). 0.14.0 works in the Unity editor on Windows, but 0.19.1 shows a missing dll error. Should it work in the editor?


When running in Unity Editor I got this error:

DllNotFoundException: libInterceptOpenXR assembly:<unknown assembly> type:<unknown type> member:(null)

Thanks for the answer, but I think there is a general problem with running sample scene. Please see the attached screen. I am running a basic sample Main Menu. I think I have completed the configuration correctly. In the editor and on Android build I have errors.


Sorry I misunderstood and thought this was a runtime error. Please try deleting your intermediate folders (library etc.) and try making a clean build. 

Just to verify, these errors are keeping you from building? I checked with our SDK engineers and they mentioned that this should not cancel the build process. 

I can make a build, but when the application starts, the same errors as in Unity Editor appear.

These errors usually only happen in a Windows environment. Could you post a log? 

We're tracking the errors in the editor already and are scheduling them for a fix. They should not have any influence on the built apk though. 

Please see the logs from the sample project run on the Android Argo device.


Hi Tomasz,

I cannot see the errors from the editor in the log you sent. The log also looks somewhat incomplete. Can you please make sure that you upload a log containing the Unity OpenXR Diagnostic? It looks something like this:

I think there are no errors or XR logs, because in the build there is 'error' for XR Initialization:

<i>AndroidPlayer "DGL_ARGO@ADB:761f3edf:0"</i> UnloadTime: 1.891927 ms
<i>AndroidPlayer "DGL_ARGO@ADB:761f3edf:0"</i> No active UnityEngine.XR.ARSubsystems.XRSessionSubsystem is available. Please ensure that a valid loader configuration exists in the XR project settings.

Could you please provide the version of Snapdragon Spaces installed on your Digilens device? 

I cannot attach here: 


It is SnapdragonSpacesServices_0_19_1.apk from your official download link:

Hi Tomasz,

Unfortunately, we ran into a rather tough situation here:

  • The gaze pointer will likely work when upgrading to a newer version of the Snapdragon Spaces SDK because starting 0.15.0 it uses the composition layers. Have you tried the 0.17.0 SDK yet?
  • The 0.19.1 SDK is not working with Argo because of changes made to the SDK that would require Digilens to make firmware changes to the device.

We have a workaround suggestion for using 0.19.1 that may work. Try the following commands

adb shell getprop persist.sxr.camname

adb shell setprop persist.sxr.camname tracking

adb shell getprop persist.sxr.camname

This may not persist a device reboot but please check:

adb reboot

adb shell getprop persist.sxr.camname

Since this support channel isn't normally for the Argo device, I lack the means to verify this workaround. 


When running in Unity Editor I got this error:

DllNotFoundException: libInterceptOpenXR assembly:<unknown assembly> type:<unknown type> member:(null)

I have a suggestion for the error in the above part.
We also had the same problem in the editor and this part seems to be caused by incomplete exception handling.
When we added an exception to the part that imports dll so that it doesn't bring up Android's dll, we could see that it worked normally without errors.



Login to post a comment