Start a new topic

Issues installing new Android 13 apps


My Edge+ is now running Android 13, and I've read posts suggesting to open the UDC app and check for updates to pull the new apps (TR Cast, etc). However, when I do so, it sits with a loading screen "Processing..." forever. What should I do to get the updated apps?



Hi Harrison,

To find the potential root cause of the issue, I need the following information:

1) Android build number;

2) Version of UDC app. 



Thanks for your help, Norbert.

1) Android build number: T1SH33.35-23-22

2) Version of UDC app:

Hi Harrison,
Can you also send me your UDC logs?

ADB command:  adb pull /sdcard/Android/data/ 


Find attached. Thanks!

(48.9 KB)


Just checking back in to see if you have any suggestions or insights.

Appreciate your help.

Hi Harrison, 

Sorry for the delay in getting back to you. We have fixed the issue with the devices not getting the latest apps. 

The next time your device comes online, you should receive prompts to uninstall the previous versions of the apps. Once the previous apps have been uninstalled, click on 'Check for Updates'. This will initiate the install of the new apps for your device. 

Please let us know if you are still having any issues.


Good to hear, I'll give it a try!

Is there anything special I need to do, such as booting the phone with glasses connected?

I just started it up fresh from shut down (glasses currently disconnected), but I didn't get any prompts to uninstall apps.  I tried going to the UDC app and searching for updates, and this time it actually prompted me to update the UDC app. I did so, and then I tried checking for updates again. It no longer hangs on "processing" as previously, but instead comes back with a message of "No updates available." 

Thanks again.

Nevermind, it worked after shutting down and starting up with the glasses connected :) 

Login to post a comment