Start a new topic

Particle system not displayed in URP

I use unity 2020.3.37f1 and upgrade my project to urp.Particle system appears normal in edior bu not  displayed in A3 glasses. Some custom shaders  may have  the same thing happen.

Thanks for sharing!  We're all learning.


I solved this problem,cause i enabled soft particles in the urp particle material.Soft particles require depth texture while  depth texture  is not enabled in the urp render settings. This may work correctly in editor but will not display in A3 glasses.



Do you have confirmation of this project displaying the particles fine on Android mobile using Linear Colorspace and OpenGLES3 (running just on the mobile, built without XR enabled)? If you do, we can see if there's an issue with the OpenXR rendering pipeline.

Hi Zhangzhengtao 

While we recommend URP for performance reasons, it's not absolutely necessary. If you have shaders that worked in a previous build but are problematic in URP and you can see other assets in the A3 glasses then you will have to debug your shaders for use in URP or revert from URP.

Snapdragon Spaces Support

Login or Signup to post a comment