Start a new topic

Application does not display in glasses

I am trying to create a "Hello World" AR application in Unity which will display four of the panda meshes from the Snapdragon Spaces Samples as the user looks around. However, when I run my application on the handset, I do not see anything in the AR glasses. The Snapdragon Spaces Controller does show up on the handset.

I am using the Lenovo ThinkReality A3 with Moto Edge+. The Snapdragon Spaces Service on the handset matches the download I am trying to use in Unity (versions at bottom of message). I have verified that the Snapdragon Spaces Samples app works as intended for both the handset and the glasses.

I have two projects available on Google drive linked below. The first one (AR-02) is the one I would like to get to work. The second one (AR-03) is when I tried to drop the sample Plane Detection into a scene. Neither of these display in my glasses. Can someone tell me what I am missing?


A3 Firmware: A3_user_S1040001_2208180059_sdm710_postcs8
UDC version:
Snapdragon Spaces Services 0.13.0

Hi Shicks,

Your A3 firmware is not up to date. In case you are running Android 13 on your Motorola edge, it is possible that this is causing a black screen. Please take a look at the FAQ for this issue:

If it is still not working after updating your glasses, please inform me and I am going to look at your projects.  

Hi Simon,

Thanks for the suggestions. However, I am not running Android 13. I am on a Motorola Edge+ (2022). From the about:

Android 12

Version: S3SHS32.12-41-4-4

Security Patch: Feb 1, 2023

When I check for Android updates, Android says I'm up to date. Is there a specific image you would like me to flash on this device? If so, can you link the URL?

I also checked for updates in the Lenovo Universal Device Client. It did not find any updates. However, I noticed that there is a newer version of UDC ( in the Play Store. I installed this, and it does not report a firmware, only an ID of 6f27aa396d0004500. If I check for updates in this app, it says "Updates are being processed", but I haven't seen any other progress or messages in about 30 minutes.

There are now two versions of UDC on the device. Should I uninstall my older version (


Login to post a comment