Start a new topic

Not installing ANY apps

I've tried everything. I did check for updates in UDC (100% of the times said it had no updates), did the factory reset on the phone and setup many times, but it is still not installing the A3 Home, Companion, AR Cast, etc apps. 

It seems these apps are required for things to work well, because when I install the apks of Snapdragon (SnapdragonSpacesServices_0_13_0.apk and SnapdragonSpaces_Unity_Samples_0_13_0.apk) directly using adb, the demo doesn't work (black screen), and when the demo app is not running, on the glasses I see what's on the phone screen but fragmented.

Do you know how to factory reset the glasses ?

What would you advise me to do?

Thanks so much in advance for your help.


There is an issue where your phone will lose access to Lenovo apps when updating your Motorola Edge to Android 13. We are expecting an update that is still tbd. I'm looking into a workaround and will come back to you about this. 

(Here is a related forum thread  Helpdesk : Qualcomm

Can you confirm that you have set all permissions (Camera and Display over other apps) in the Spaces Services and Samples? 

Hi Simon, I can confirm that all the permissions have been set correctly.

Could you please provide a logcat of starting an application with blackscreen? That could already help investigate. 

Loosing access to Lenovo apps should not block spaces apps from running. 

Just to be sure I'm grasping this issue right - you are running Android 13 or 12? 

Definitely. Attached is logcat for the moment I open the Unity demo, I see the control on the phone and black screen on the glasses.

I'm also attaching an screenshot of the latest software version of the phone


Hi Simon, 

Let me know if you need anything else from me that could help you investigate the issue.

Thank you so much for your help!

Hi, we are looking into the log - might take some time though. 

On a first glance it seems like something is going wrong within the services. There is a couple of potential permission violations there as well. 

Could you try to cleanly reinstall your Snapdragon Spaces Services?

  1. Uninstall services and samples
  2. Shutdown your phone (do not press restart)
  3. Turn on your phone again
  4. Install the apps via adb and do not use the -g option for the services
  5. Give all permissions to services and samples

Are you using the pre-built samples coming with the SDK package or an apk built by yourself? 


Just tried all your steps a few times to make sure, last one I even factory reset the phone and did it all again.

Same results, the apps load on the phone, but on the glasses is just black.

I'm using the pre-built samples that come with the SDK

Hey Simon, do you know if there is a way for me to factory reset the glasses ?

Login to post a comment