Start a new topic

Hit testing sample fails to find planes

Simply put I can't seem to get the hit testing sample functioning as expected. Every time I activate the "Hit" button I always get the indicator flashing red, despite my various attempts at positioning my head at varying angles and distances from surfaces. I'm seeing this in both in the prebuilt Unity samples APK and my own builds (I'm using SDK version 0.6.1).

To debug I tried modifying the sample scene by manually adding an AR Plane Manager with a Plane Prefab (also modified to remove the Mesh Collider, in case that interferes) to confirm planes are being detected. I can now see there are several planes created in my testing environment but hit tests continue to fail. 

I understand this is an experimental feature but it's quite central to out use-case so any help would be appreciated :) 

1 Comment

Seems the SpacesService was not updated to 0.6.1 along with the other updates that we're pushed to my device. Manually updating it with `SnapdragonSpacesServices_0_6_1.apk`provided in the SDK download has solved the issue.

Login to post a comment