Think Reality VRX SDK Compatibility

Attention all developers using VRX on the latest firmware 933 & 980 with Snapdragon Spaces Services 0.19.3:  


Please note that the newly released Snapdragon Spaces SDK 0.21.0 is currently NOT officially supported until a firmware update with a newer version of the Snapdragon Spaces Services for VRX is released.   

 

Forward and Backward Compatibility

Forward compatibility from a newer version of the Snapdragon Spaces Plugin to an older version of the Snapdragon Spaces Services is not guaranteed. As such, we recommend that developers using VRX on firmware 933 & 980 continue to stay on the Snapdragon Spaces Plugin 0.19.1 in the meantime.  


Backward compatibility from an older version of the Snapdragon Spaces Plugin to a newer version of the Snapdragon Spaces Services is guaranteed.  


For more detailed information about forward and backward compatibility of the Snapdragon Spaces Plugin and Services, please refer to Snapdragon Spaces Forward and Backward Compatibility (Qualcomm.com) 


Where to download older versions of the SDK?

To access previous versions of the SDK, please visit the Snapdragon Spaces Developer Portal download page Download | Snapdragon Spaces (Qualcomm.com) and scroll down. 

At the time of writing, versions 0.21.0, 0.19.1, and 0.17.0 are available for download. Should you require an even older version of the Snapdragon Spaces SDK, please reach out to support@spaces.qualcomm.com or create a support ticket Submit a ticket : Spaces Snapdragon Forum (Qualcomm.com). 


Edit: Changed link to detailed information on forward and backward compatibility to the new documentation page. 

@Simon


Hi, VRX new firmware version "980" was released.

We've already upgraded to latest firmware.


Is the Snapdragon Spaces v0.21.0 still officially NOT supported ?

and do we have to still use v0.19.1.1?

Hi,


the VRX 980 firmware is still based on 0.19.3 Spaces Services. Here a chart of the mapping https://support.spaces.qualcomm.com/a/solutions/articles/72000616577

Hence you will need to continue using the 0.19.1.1 Plugin. I updated the original post to reflect this. 

@Simon


Thank you for sharing information.


We decide to use 0.19.x plugin for the VRX 980.

Login or Signup to post a comment