Start a new topic

Issue with Lenovo VRX App and Qualcomm Service Update

I want to inquire about an issue we're facing with  the Lenovo VRX device. We've been trying to enable hand tracking, but it's not working. To check this, we updated the Qualcomm service to version 15. However, after this update, the Lenovo VRX UI(Home) disappears and doesn't display properly. When we restart the Device, it briefly appears for about 2 seconds and then turns into a black screen. We also attempted to remove the service using ADB commands, but that didn't resolve the issue. Do you have any suggestions or solutions to help us resolve this problem?

Unfortunately, you cannot use hands and controllers at the same time, as controllers emit infrared light that will disrupt the hand tracking model.
There is a plan to enable switch with controller button or automatic set up when you should be able to switch to hands if controllers are set on the table. Engineering team is working on implementing this in the next VRX builds.

I am wondering if there is a fix for simultaneously using hands and controller as of now.

We are facing the same issue on our side, we still have to remove the controller batteries.

HI Afedorch,
This solution works for me after I  get SD's latest VRX image update.

Hi Daniel,

The hand tracking only works if you lunch the app with controller like Unity Sample and then pull the batteries out. This is a temporary hack, while SDK team is working on more elegant solutions.
We apologize for all the inconvenience. Plese let me know if it works for you, also what build number is your device is on?

Hello! We are having the same problem with hand tracking on Lenovo device, we have tried all the suggested alternatives we have seen here. Have any solutions been found?

Many thanks for all the files, this is super helpful I verified the issue and started interaction with engineering team on fixing this issue.

1 person likes this

I have sent an email with the log file attached.

Hi Afedorch,

Thank you for looking into this hand-tracking issue. I've attached the log files for your review. If further discussion or clarification is required, please feel free to reach out to me at

My availability for a meeting is within Indian IST, from 9 AM to 7 PM. Please schedule a meeting at your convenience if needed.

Looking forward to your feedback.





(23.6 KB)

We can connect over a call to go over the hand-tracking issue. I will ask you to generate some logs for me so we can do a deeper investigation. Also, I want to see if I can get a later build on VRX. Here is my email. Feel free to look at my schedule if you have teams, or you can give me your email, and I can schedule something.

1 person likes this

Thank you for your prompt response and suggestions.

We did obtain the Spaces Hand Tracking Sample Demo from SDK 15 initially and encountered issues with it. Subsequently, we also tried SDK 17, but unfortunately, the hand-tracking functionality remained non-functional.

Regarding the registration of our device with Lenovo Hub, we don't have that information readily available. The device configuration was already in place when we received it, and we haven't made any changes to it ourselves. We are in the process of reaching out to our Lenovo partners to gather more information on this matter.

If you have any further insights or recommendations on resolving the hand-tracking issue, we would greatly appreciate your assistance.





Thanks for the replay.  We get the Spaces Hand Tracking Sample Demo from SDK 15. We can try SDK 17 and let you know the status.

Hi and Thanks for reporting where did you get the Spaces Hand Tracking Sample Demo from SDK 15 if so you should try the new SDK that just came out SDK 17. Also do you know if your device got registered with Lenovo Hub or you did not register your device with any one yet?

1 person likes this

When we lunch snapdragon space hand traking sample demo. It gives a Hand tracking not found error. 


1 person likes this

There is no update option available. 


1 person likes this

The app gives There is No hand tracking available ERROR


We checked Thinkreality VRX document but there is no software update button available.


Login to post a comment